Problem
404 Error displays when end user submits a Services and Support form:

Cause
Possible reasons for the Error Code
- Stale log in
- Bad or outdated link
- System timed out
- Browser issues
Try to log out and log back in to Service and Support and follow the solution steps below
Solution
Check to see if your Request has been submitted
- On Services and Support Home Page, click on My Stuff
- From the drop down menu Select Tickets :
- Check to see if the Request you submitted is listed
- If it is, there is no need to take further action, we have received your Request and it will be processed in the order received
- If you do not see your Request as open, try opening a different browser and re-submit the appropriate request