CMS Error: "Asset is not set to publish"


Problem


When publishing, you get the CMS error: "Asset is not set to publish. Please enable publishing for this asset and try again."

Cause

Pages and folders in the CMS can be disabled for publishing.

Solution


If you can't publish an asset (folder, page, image or file) within the CMS and you're presented with the following error:

"Asset is not set to publish. Please enable publishing for this asset and try again."

Then you need to enable publishing. Follow the instructions for Disabling Publishing, but make sure the box next to Include when publishing is checked.

Note: If the asset is enabled for publishing but you still get the error message, check the folder one (or more) levels up (this setting will cascade down to the entire folder hierarchy). Some assets, such as block content, aren’t publishable. Instead of publishing the block, you publish the page the block shows up on.

If you still have questions or need additional assistance, contact wts@ucsd.edu.