Problem
When attempting to login to a Duo-protected application on iOS or macOS, the Duo prompt doesn't show, and instead the following error message appears:
You cannot browse this page at "duo.com" because it is restricted
You may see a gray box appear instead of the Duo prompt in some cases.
Cause
- This issue may happen if Javascript is not enabled in Safari.
- This also may happen if you have an MDM on the device, such as JAMF, which could be preventing Duo from displaying.
- Content restrictions on the device may also prevent the prompt from appearing.
Solution
For iOS 12 or newer:
- Navigate to Settings > Screen Time > Content & Privacy Restrictions > Content Restrictions > Web Content
- Uncheck Limit Adult Websites to completely disable content restrictions.
- If you do not want to fully disable content restrictions, you can allow duosecurity.com within the Content Restrictions page
on the iOS device.
- If you are opening Screen Time for the first time, you will be prompted to set up the phone for either yourself or a child, and have the option to set a passcode.
For iOS 11 or older:
- Go to Settings > General > Restrictions > WebsitesUncheck Limit Adult Content to completely disable content restrictions.
- Uncheck Limit Adult Content to completely disable content restrictions.
For macOS 10.15 (Catalina) or higher:
- Open System Preferences
- Navigate to Screen time > Preferences > Content and Privacy
- Set any Web Content restrictions to Unrestricted access
- If you do not want to fully disable content restrictions, you can allow duosecurity.com within the Allowed Websites Only list on macOS.