Kaltura Troubleshooting: Kaltura Capture Videos Have Audio and Video out of Sync


Problem


When playing back a recording made with Kaltura Capture, the audio and the video are out of sync.

Cause

This is likely caused by the inability of your computer to record your screen, camera, and microphone effectively. Screen recording software is particularly memory- and processor-intensive. This appears to happen more often to Mac users than Windows users. 

Solution


With regard to your existing recording, if you want to address the de-syncing, you'll have to drop it into editing software on your computer (e.g. iMovie) and manually adjust the audio/video timing. What we CAN help with is hopefully preventing this with future recordings. 

  1. Reboot and close extraneous applications
  2. Reduce the quality of your recording
  3. Use something else to record

1. Reboot and Close Extraneous Applications

It may sound like a basic solution, but a reboot can result in considerable improvement in overall computer performance, particularly if you haven't rebooted in a long time. (A good rule of thumb is to reboot your computer every 2-3 days.) In addition, some pieces of software take up surprisingly large amounts of system resources and can reduce your recording quality significantly. 

With this in mind:

  1. Reboot your computer.
  2. Make sure that the only applications you have open on your computer are those that you need to capture during your recording. If using a web browser, ensure that the only tabs open are those that you intend to demonstrate during the screen capture.
  3. Do a sample recording (maybe a minute long) with the same or similar settings as a "normal" video you'd record (e.g. camera, microphone, screen capture, and a PowerPoint presentation running). See our KBA Record a Video with Kaltura Capture if needed.
  4. Wait for the recording to upload and finish processing.
  5. View the video within "My Media" in Canvas or MediaSpace. 

If the video still has sync issues, try the next solution.

2. Reduce the Quality of Your Recording

A screenshot of the "settings" section of Kaltura Capture.Capturing your camera, microphone, and/or screen is very taxing on your computer's resources. Depending on the age and computing power of your machine, it's possible that it's struggling to keep up with the quality level of the recording that you've requested. Try reducing your recording quality and see if it improves things. 

Here's how to adjust your recording settings:

  1. Open Kaltura Capture on your computer. If you're not sure how to get there, you can open it in MediaSpace via the following steps:
    1. Go to https://mediaspace.ucsd.edu.
    2. Click the profile icon at the top right of the page and select Login.
    3. Enter your active directory credentials.
    4. Click the +Create button at the top of the page and select Capture.
  1. Once Kaltura Capture is open, click Manage.
  2. Click the gear icon on the left side of the window that opens.
  3. Try changing both the "camera recording quality" and "screen recording quality." You can first try 720p and then bump it down to 480p if needed later.
  4. After making changes, click Save.
  5. Record a test video, maybe a minute long, mimicking the style of video you typically do (e.g. microphone, video, and screen capture of a PowerPoint presentation). Upload the video when your recording is complete.

Once the video is fully processed, watch it in "My Media" in Canvas or MediaSpace. If the sync issue is gone, you can try to tamper with the quality settings to maximize quality. 

3. Use Something Else to Record

Kaltura Capture ain't everyone's cup of tea. Or maybe it just hates your computer. If you just can't get rid of the syncing issue, you may just want to use something else. Zoom is probably your best bet. Remember too that we have an integration set up between Zoom and Kaltura; whenever you record something to the Zoom cloud it will automatically make its way to your "My Media" in Canvas/MediaSpace. Check out our KBA titled Record a Video to the Zoom Cloud if you need some guidance. 

If you continue to experience sync issues, or if you have a powerful/new computer that is still encountering this, please write us at kaltura@ucsd.edu and provide the following information:

If you still have questions or need additional assistance, feel free to contact us at kaltura@ucsd.edu.