Kaltura Troubleshooting: Kaltura Capture Not Uploading


Problem


A screenshot of an error message.Sometimes Kaltura Capture may fail to upload a recording you've completed. Luckily, the way Kaltura Capture works is that it records to your computer and then attempts to upload the entirety of the recording afterwards. 

Cause

There are several reasons why you might be experiencing this, such as Kaltura's server load, a poor internet connection, an outdated application, or corrupted configuration files. 

Solution


There are a few steps you can take to try and address this issue. We recommend you try these in order. 

  1. Update Kaltura Capture
  2. Use Kaltura Capture's interface to re-upload
  3. Delete your configuration files and attempt to re-upload
  4. Find the files on your computer and upload them manually

1. Update Kaltura Capture

One particularly irksome thing about Kaltura Capture is that you can't update it manually. Kaltura tells us that if you leave the application open for a few minutes it will auto-update, but we've found this to be unreliable. So:

  1. Uninstall Kaltura Capture. Follow the steps you'd take to uninstall any other program on your computer.
  2. Reinstall Kaltura Capture. See our KBA if needed: Install Kaltura Capture Within Canvas or Install Kaltura Capture Within MediaSpace

2. Use Kaltura Capture's Interface to Re-Upload

A screenshot of Kaltura Capture settings.Once you're sure you have the latest version of Kaltura Capture, use it to force the recording to re-upload. 

  1. Open Kaltura Capture on your computer. If you're not sure how to do that, you can launch it from MediaSpace or Canvas. Since everyone has access to MediaSpace, here are those instructions:
    1. Go to https://mediaspace.ucsd.edu.
    2. Click the profile icon at the top right of the page and select Login.
    3. Enter your active directory credentials.
    4. Click the +Create button at the top of the page and select Capture
  2. In the little application window that opens, click Manage.
  3. Make sure the Library tab is selected in the left navigation. (It looks like a folder.)
  4. In your list of recordings, find the one in question and click Re-Upload. (It may also say Upload if there was an issue uploading it initially.)
  5. Wait for the upload to complete before closing Kaltura Capture. Ensure that your recording ends up in "My Media" and that it processes correctly.

If your recording still doesn't upload, move on to the next step. 

3. Delete Your Configuration Files and Attempt to Re-Upload

This step involves finding Kaltura Capture's configuration files on your computer and deleting them. It will NOT delete any of your existing recordings. The challenge is really just locating the folder on your computer.

Show Hidden Files / Folders

Your Kaltura Capture settings (and recordings) may be within a "hidden folder." If you attempt to navigate to the directory that Kaltura Capture tells you where your files are located and you hit a dead end, you may have to tell your computer to show hidden files:

You may want to go back to hiding files when you're done following all the steps in this troubleshooting document. 

  1. Navigate to the folder where your Kaltura Capture settings are kept.
    1. Mac: /Users/[your username]/Library/Preferences/Kaltura/Capture/Settings
    2. Windows: C:\Users\[your username]\AppData\Local\Kaltura\Capture\Settings\
  2. Delete all the files within the "Settings" folder.
  3. Re-launch Kaltura Capture. (Note that you may be asked to launch it from the web. If so, go to MediaSpace, log in, and click +Create > Capture. You can also launch Kaltura Capture from Canvas.)
  4. Follow the steps from step #2 above to try and re-upload your recording(s).

4. Find the Files on your Computer and Upload Them Manually

The last thing you can do if nothing else works is to find the recording files on your computer and manually upload them to Kaltura. It's a bit of a pain, but it will work. If you recorded your screen and your camera, you'll need to choose which video you want to upload - this won't be a dual-stream video.

  1. Open Kaltura Capture on your computer. If you're not sure how to do that, you can launch it from MediaSpace or Canvas. Since everyone has access to MediaSpace, here are those instructions:
    1. Go to https://mediaspace.ucsd.edu.
    2. Click the profile icon at the top right of the page and select Login.
    3. Enter your active directory credentials.
    4. Click the +Create button at the top of the page and select Capture
  2. In the little application window that opens, click Manage.
  3. Click the gear icon on the left side of the window.
  4. Observe the directory that's listed next to "current recording directory," and navigate to it on your computer. 
  1. Once you're in the appropriate folder, here's where you'll have to do a little bit of sleuthing. Focus on the files that have a .mp4 extension. You'll probably want to target files that were created on the date you recorded your video, and you'll probably need to play them to figure out which one is the one you want.
  2. Once you find the file you want to upload, follow our tutorial on how to upload a file to Kaltura (if needed).
If none of the solutions are working or you need additional assistance, feel free to contact us at kaltura@ucsd.edu.