Problem

When you click on a Media Gallery, channel, or piece of media, you see a page with an "Application Error" message at the top of the page. This can occur both in Canvas and MediaSpace and can affect all users (students, instructors, staff, etc.).
Causes
The most likely reason for an Application Error is a Kaltura bug. Kaltura is a third-party enterprise vendor who provides video hosting and delivery services to UCSD. Errors like these occur from time to time - especially within Canvas - due to the complexity of its LTI integration and frequent updates.
Workarounds
Application errors are often difficult or impossible for local UCSD technicians to troubleshoot, since the issue is often only something Kaltura can fix. So the best thing we can do is to offer workarounds, but even these are generic since an application error can arise for a variety of reasons.
- Do the simple stuff first. You know, log out/in, try another browser, and even reboot. You always have to start with the simple stuff so you can cross it off the list.
- Try using the Canvas mobile app. By this, we mean the application that you download from the Google Play Store or Apple's App Store. That is, not just looking at the page in question on your mobile browser.
- If applicable, attempt to view the video on the podcast website (https://podcast.ucsd.edu). If the application error is occurring when you're trying to watch a podcast (lecture capture) video, there's a chance that the video will be fine on that external website. Note that your instructor will have had to have configured their podcast to be visible on the podcast website. (That said, most do.)
- Try seeing if you can access the page without using the vanity URL. The typical URL we use for canvas is canvas.ucsd.edu. But that's technically a "vanity URL" that points to https://ucsd.instructure.com. So try using that URL as a base instead of canvas.ucsd.edu. Just be aware that ucsd.instructure.com shouldn't become your primary way of accessing Canvas, as some UC San Diego services and tools may not function properly outside of the official canvas.ucsd.edu environment. If you encounter issues using that URL, return to using canvas.ucsd.edu.
If none of these solutions work, contact kaltura@ucsd.edu and let us know what's going on and what you've tried. Be as specific as possible about what you're trying to access (what video, what course, etc.).