Troubleshooting: "Current Balance is Not Available" Error in TritonPay


Problem


If you see the message "A current balance is not available at this time" in the Summary section of TritonPay, it usually indicates a temporary connection issue between campus servers and the payment environment.

 

Common Causes

 

Recommended Steps


If you see this error outside of the maintenance window, please try the following:

  1. Clear your browser cache and cookies, then restart your browser.
  2. Open TritonPay in an Incognito or Private window.
  3. Wait 15–30 minutes and try logging in again.

 

Financial Aid and Deadlines


If you still have questions, please submit a ticket.